lotrointerface.com
Search Downloads


Go Back   LoTROInterface > LotRO Stand-Alone Plugins > Action Bars & Main Bar


Post A Reply
Author Comments Comment Options
Unread 01-17-2024, 11:52 AM  
lotrofamily
The Wary
 
lotrofamily's Avatar

Forum posts: 4
File comments: 34
Uploads: 0
Re: Re: Extension vanishes before item can be selected

Quote:
I can't reproduce this locally, can you send me your tonicbarSettings.plugindata file?
Sure! How do you want me to do that, please?

FYI: the "pets" bar group works fine
It's the "mounts" one I'm having the issue with.

It's probably user error at some point, so I apologise in advance for how messy my file is likely to look!

Last edited by lotrofamily : 01-17-2024 at 11:54 AM.
lotrofamily is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-17-2024, 08:47 AM  
NuclearTonic
The Undefeated
 
NuclearTonic's Avatar
Interface Author - Click to view interfaces

Forum posts: 8
File comments: 247
Uploads: 1
Re: Extension vanishes before item can be selected

Quote:
It's like it believes I'm no longer on mouseover. I decreased the spacing to 0, to no effect, as I think it's to do with the gap between the "root" icon and the extension bar, which I don't think we can control?
I can't reproduce this locally, can you send me your tonicbarSettings.plugindata file?

Last edited by NuclearTonic : 01-17-2024 at 08:47 AM.
NuclearTonic is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-17-2024, 06:21 AM  
lotrofamily
The Wary
 
lotrofamily's Avatar

Forum posts: 4
File comments: 34
Uploads: 0
Extension vanishes before item can be selected

Hey,

Thanks for doing work on this. I've been using TonicBars since I first discovered it last year when doing a blog on LOTRO plugins.

Since the update, though, some extensions have been weird. So I mouse over the item that has an extension 'under' it but moving my cursor over the extension bar it vanishes.

It's like it believes I'm no longer on mouseover. I decreased the spacing to 0, to no effect, as I think it's to do with the gap between the "root" icon and the extension bar, which I don't think we can control?

If you need me to do something to dig into this, please let me know. And if it's dumb user error, just tell me off instead. Thanks!

Thanks,

- FJ
lotrofamily is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-16-2024, 07:48 PM  
NuclearTonic
The Undefeated
 
NuclearTonic's Avatar
Interface Author - Click to view interfaces

Forum posts: 8
File comments: 247
Uploads: 1
Thanks for working through these with me everyone. Remember this codebase is 14 years old. It was developed when I had three kids under two running around and I needed a break. At the time I didn't have the time to correct every issue the "right" way, I was also missing some tools, Turbine had bugs at the time too, etc.

I'm taking the time now to actually fix problems, rearchitect it to make sense. I'm mostly through this, although there are a few areas I still need to correct, it's mostly there. I appreciate you all helping me to find these, surface them and address them!
NuclearTonic is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-16-2024, 01:40 PM  
NuclearTonic
The Undefeated
 
NuclearTonic's Avatar
Interface Author - Click to view interfaces

Forum posts: 8
File comments: 247
Uploads: 1
Quote:
Take all the time you need just let us know when it is done
Yours should have been fixed with: v3.2.3!
NuclearTonic is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-16-2024, 10:18 AM  
bsmorgan
The Undefeated

Forum posts: 7
File comments: 69
Uploads: 0
Quote:
Give me a few hours.
Take all the time you need just let us know when it is done
bsmorgan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-15-2024, 12:22 PM  
NuclearTonic
The Undefeated
 
NuclearTonic's Avatar
Interface Author - Click to view interfaces

Forum posts: 8
File comments: 247
Uploads: 1
Re: Error loading MysticBars v3.2.2

Quote:
Here is a link to the settings on my system.
Thank you, this will give me everything I need to reproduce the problem! Give me a few hours.
NuclearTonic is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-15-2024, 11:45 AM  
bsmorgan
The Undefeated

Forum posts: 7
File comments: 69
Uploads: 0
Error loading MysticBars v3.2.2

I opened the Plugin Manager and attempted to "Load" MysticBars. This resulted in the following error:

[01/15 09:41:02 AM] ...line\Plugins\MysticBars\Services\SettingsServic e.lua:310: attempt to index local 'newpath' (a nil value)

I haven't logged in since I "converted" TonicBars 2.9.1 to MysticBars. I'm not sure any upgrading actually took place (see my comment on 1/2/2024).

Here is a link to the settings on my system.

Last edited by bsmorgan : 01-15-2024 at 12:12 PM.
bsmorgan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-14-2024, 06:37 PM  
NuclearTonic
The Undefeated
 
NuclearTonic's Avatar
Interface Author - Click to view interfaces

Forum posts: 8
File comments: 247
Uploads: 1
Quote:
After repositioning the quickslot bar, the extension bars are again correctly "pinned" on the correct quickslot button.
I can't reproduce this, can you send me your bars? The error you quoted, earlier, is ok, its because you tried to add an extension to an extension.

[01/14 01:27:49 PM] You can not add an extension to an extension.
[01/14 01:27:49 PM] ...nline\Plugins\MysticBars\Bars\Core\QuickslotLis t.lua:210: attempt to index local 'extBar' (a nil value)
NuclearTonic is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-14-2024, 04:57 PM  
Mac2
The Wary

Forum posts: 0
File comments: 5
Uploads: 0
One additional information ... it looks like the error message is not coresponding to the "position problem" of the extension bars.

Up to now, I could not reproduce the error message.
But after each new login (on all characters), the position of the extension bars is reseted near the upper left corner.
After repositioning the quickslot bar, the extension bars are again correctly "pinned" on the correct quickslot button.

The movement of the quickslot bar can be done via "plugin edit mode" or via "strg + #" shortcut.

thanks,
Mac
Mac2 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-14-2024, 11:53 AM  
NuclearTonic
The Undefeated
 
NuclearTonic's Avatar
Interface Author - Click to view interfaces

Forum posts: 8
File comments: 247
Uploads: 1
Quote:
[01/14 01:27:49 PM] You can not add an extension to an extension.
[01/14 01:27:49 PM] ...nline\Plugins\MysticBars\Bars\Core\QuickslotLis t.lua:210: attempt to index local 'extBar' (a nil value)
Thanks, I'll look into this issue too.
NuclearTonic is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-14-2024, 07:33 AM  
Mac2
The Wary

Forum posts: 0
File comments: 5
Uploads: 0
Hi,
sorry for the confusion. Because of problems with my first forum account, i've to create another (Mac == Mac2).

After the new update the plugin loads as expected. Thanks for the quick fix!

And maybe a hint for everyone ... I noticed that the extensions bars, which I created before, were no longer "connected" to the quickslot bar.
But after moving the quickslot bar a little bit around (in edit mode), the extension bars "reconnect" to the quickslot.

Afterwards the following message appears in the chat after loading the plugin:

[01/14 01:27:49 PM] You can not add an extension to an extension.
[01/14 01:27:49 PM] ...nline\Plugins\MysticBars\Bars\Core\QuickslotLis t.lua:210: attempt to index local 'extBar' (a nil value)

But it looks like the plugin is loaded successfull and everything works as expected.

best,
Mac
Mac2 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-13-2024, 09:06 AM  
NuclearTonic
The Undefeated
 
NuclearTonic's Avatar
Interface Author - Click to view interfaces

Forum posts: 8
File comments: 247
Uploads: 1
Ok, I found it, will push a fix shortly, thank you for letting me know!

Last edited by NuclearTonic : 01-13-2024 at 09:08 AM.
NuclearTonic is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-13-2024, 08:15 AM  
NuclearTonic
The Undefeated
 
NuclearTonic's Avatar
Interface Author - Click to view interfaces

Forum posts: 8
File comments: 247
Uploads: 1
Quote:
Do you have any ideas if there is a problem with updating from 3.1.6 ?
Yours is the first report. The thing that changed is that bars now have an Id field, it should have auto-upgraded that for all yours bars. Send me your .plugindata file and I'll get your running again. Do you have any ideas what you were doing when this happened? Just upgrading? I can't seem to reproduce this just upgrading standard bars. Did you have inventory bars? Bar Extensions?

Last edited by NuclearTonic : 01-13-2024 at 09:02 AM.
NuclearTonic is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-13-2024, 07:12 AM  
Mac2
The Wary

Forum posts: 0
File comments: 5
Uploads: 0
Hi,
after updating yesterday from 3.1.6.2 to 3.2.0 I got the following error on all chars:

[01/12 05:30:41 PM] ...ings Online\Plugins\MysticBars\Bars\Core\BaseBar.lua:78 : attempt to concatenate field 'id' (a nil value)

After my last problem with updating to 3.1.6, I started with a complete "fresh" installation, and Rebuilded all of my Bars. So all configurations should be correct "3.1.6-like".

Do you have any ideas if there is a problem with updating from 3.1.6 ?

thanks,
Mac
Mac2 is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 07:56 AM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | ESOUI | LoTROInterface | MMOUI | Swtorui