Quantcast
VGInterface.com
Search Downloads


Go Back   LoTROInterface > Outdated LotRO Interfaces


Post A Reply
Author Comments Comment Options
Unread 09-26-2010, 12:18 AM  
Skald
The Wary

Forum posts: 3
File comments: 9
Uploads: 0
Like the others, had to roll back as well sadly. I really love this addon and think its one of the must haves since it is so functional.
Skald is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-26-2010, 12:01 AM  
Hethbot
The Wary

Forum posts: 0
File comments: 2
Uploads: 0
I went back to 1.06.2 and it works great, look forward to 1.07.2 updates.

But I also wanted to say thanks to DU for making this awesome plug-in and for sticking with it to keep making it better. YOU ROCK!
Hethbot is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 10:45 PM  
Uthboth
The Undying
 
Uthboth's Avatar
Interface Author - Click to view interfaces

Forum posts: 48
File comments: 72
Uploads: 2
It worked for me when I took out those two references for a few client restarts. After that though I started getting a new error pop-up saying that Palantir itself couldn't be loaded. I don't know what changed to cause it to start doing that, so I had to do the rollback.

Sorry I'm not able to help more, but I don't know how to work with lua script.
Uthboth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 10:31 PM  
Digital_Utopia
The Undying
 
Digital_Utopia's Avatar
Interface Author - Click to view interfaces

Forum posts: 207
File comments: 132
Uploads: 7
It was even worse for me. Had the same errors and more. Eek! I got the 1.07 version to work by editing the two files that he suggested, but this new version isn't working for me either.

Ok, just go back to 1.06.2 until I can test it on other systems then. Sorry about the problems
Digital_Utopia is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 09:45 PM  
Starcrusher
The Undefeated

Forum posts: 6
File comments: 14
Uploads: 0
It was even worse for me. Had the same errors and more. Eek! I got the 1.07 version to work by editing the two files that he suggested, but this new version isn't working for me either.

Last edited by Starcrusher : 09-25-2010 at 09:45 PM.
Starcrusher is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 08:02 PM  
Digital_Utopia
The Undying
 
Digital_Utopia's Avatar
Interface Author - Click to view interfaces

Forum posts: 207
File comments: 132
Uploads: 7
Sorry guys, I'll take a look at this and see what the problem is. Looks like it could be an import issue. Curiously enough it still works fine on my end.

I'll get another update up as soon as possible.

Edit: Made a some changes on imports, hopefully this should be fixed.

Last edited by Digital_Utopia : 09-25-2010 at 08:16 PM.
Digital_Utopia is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 07:34 PM  
Uthboth
The Undying
 
Uthboth's Avatar
Interface Author - Click to view interfaces

Forum posts: 48
File comments: 72
Uploads: 2
Well I'm having to rollback to 1.06.2 because it's not working again. Going to have to wait for DU to fix this one. :/
Uthboth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 07:05 PM  
Hollow Zangetsu
The Wary
 
Hollow Zangetsu's Avatar

Forum posts: 3
File comments: 2
Uploads: 0
hmm

by the comments below me i will not update till i see clarifacation that nothings wrong. and if nothing is wrong. will the plug-in auto update or do i have to manually delete files and then add the new ones?
Hollow Zangetsu is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 06:27 PM  
rlarsen
The Wary

Forum posts: 0
File comments: 33
Uploads: 0
Hopelessly broken at 1.07, same errors as below, complete delete and reinstall of all plugins and plugin folders accomplished nothing other than losing all my other settings. :/

Going back to previous version until fixed.
rlarsen is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 04:55 PM  
Skaaz
The Wary

Forum posts: 0
File comments: 2
Uploads: 0
Seem to be having same problems as those below. Not really sure what it is I should be editing so, did not try any of that.

I noticed in the uploads put up on 9/24/10 The Turbine folder was not included.

I went back to this one 1.06.2 09-21-2010 05:08 PM, the turbine folder is included and this version works for me. Trying to update to either versions dated 9-24-10 breaks it.

Last edited by Skaaz : 09-25-2010 at 06:04 PM.
Skaaz is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 03:40 PM  
Gleobeam
The Wary

Forum posts: 0
File comments: 1
Uploads: 0
I have been using Palantir since day of release... and when I tried updating with this version, I had the same issue the previous person mentioned. So I tried starting from scratch with it... no success... Help?
Gleobeam is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 03:30 PM  
Uthboth
The Undying
 
Uthboth's Avatar
Interface Author - Click to view interfaces

Forum posts: 48
File comments: 72
Uploads: 2
Re: Re: Re: Errors on loading

Quote:
Originally Posted by Hethbot
Quote:
Originally Posted by Starcrusher
I'm getting these errors when I try to load the plugin. The directory structure looks ok to me and other plugins load fine.

... Rings Online\Plugins\DigitalUtopia\Utilsx\Timer.lua:2: Unable to resolve package "DigitalUtopia.Utilsx.Class".

...ngs Online\Plugins\DigitalUtopia\Utilsx/__init__.lua:1: Failed to import package "DigitalUtopia.Utilsx.Timer".
I had these too, with 1.07. I fixed it (apparently, at least) by commenting out two apparently spurious imports, one in DigitalUtopia\Utilsx\__init__.lua and one in DigitalUtopia\Utilsx\Timer.lua:
Code:
--import "DigitalUtopia.Utilsx.Class";

I tried commenting out the two files you suggested, but I still had the other three errors. So I tried commenting those three as well, and now the only message I get with "/plugins load palantir" is "Unable to load "palantir"."

On a side note, it looks like a great plugin, and everyone I know who is using it successfully loves it.
I used notepad++ and I went in and completely removed the line --import "DigitalUtopia.Utilsx.Class"; in both those files. After a client restart it worked.
Uthboth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 02:46 PM  
Hethbot
The Wary

Forum posts: 0
File comments: 2
Uploads: 0
Re: Re: Errors on loading

Quote:
Originally Posted by Starcrusher
I'm getting these errors when I try to load the plugin. The directory structure looks ok to me and other plugins load fine.

... Rings Online\Plugins\DigitalUtopia\Utilsx\Timer.lua:2: Unable to resolve package "DigitalUtopia.Utilsx.Class".

...ngs Online\Plugins\DigitalUtopia\Utilsx/__init__.lua:1: Failed to import package "DigitalUtopia.Utilsx.Timer".
I had these too, with 1.07. I fixed it (apparently, at least) by commenting out two apparently spurious imports, one in DigitalUtopia\Utilsx\__init__.lua and one in DigitalUtopia\Utilsx\Timer.lua:
Code:
--import "DigitalUtopia.Utilsx.Class";

I tried commenting out the two files you suggested, but I still had the other three errors. So I tried commenting those three as well, and now the only message I get with "/plugins load palantir" is "Unable to load "palantir"."

On a side note, it looks like a great plugin, and everyone I know who is using it successfully loves it.

Last edited by Hethbot : 09-25-2010 at 03:02 PM.
Hethbot is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 01:57 PM  
skarlett
The Undefeated
 
skarlett's Avatar

Forum posts: 5
File comments: 5
Uploads: 0
[Hmm, odd. If it's loaded then it shouldn't give you that message.

First make sure you haven't somehow unloaded plugins by mistake - such as logging out and logging back in or typing /plugins unload - as that will unload everything.

Second, make sure you have the latest version, or at least a version starting with v1.0 - as the options panel in the in-beta versions (0.1,0.2 and 0.3) were accessed by typing /palsetup, so typing /palantir options would give you that "unknown command" message. I believe every version since at least 0.2 will display a "byline" in the chatbox on load, including a version number. To be absolutely safe, delete the DigitalUtopia folder in your plugins folder, download Palantir from here, and extract the DigitalUtopia folder to the same location.

Other than that, I can't think of any reason why /palantir options would result in that message, as the only way it would is if a) Palantir wasn't loaded or b) you have a version older than v1.0]
--------

Thanks for your response. I tried your suggested solution (ie deleted the DigitalUtopia folder and downloaded Palantir from here...result, could Not even load the palantir plugin, so I reverted back to the previous folder...the plugins loaded , but, alas, typing /palantir options got the same message "unknown command". If you have another suggestion, I'll gladly try it.

~Skarlett
skarlett is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-25-2010, 10:24 AM  
Starcrusher
The Undefeated

Forum posts: 6
File comments: 14
Uploads: 0
Yeah that will let it load....not sure it is working properly tho.
Starcrusher is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 08:03 AM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | VGInterface | LoTROInterface | MMOInterface | Swtorui