Quantcast
VGInterface.com
Search Downloads


Go Back   LoTROInterface > LotRO Stand-Alone Plugins > Other


Post A Reply
Author Comments Comment Options
Unread 11-01-2017, 10:11 PM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 547
Uploads: 8
Re: Compliments, errors, and a request

Quote:
One error I keep getting when I type /dtn - Error: Missing Location
If you read the documentation, the correct command is "/dtn ;loc" because the plugin can't determine your location without the ";loc"
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-22-2017, 06:57 AM  
Pineleaf
The Wary
 
Pineleaf's Avatar

Forum posts: 0
File comments: 5
Uploads: 0
I noticed that in the latest update to the game, Standing Stone corrected the spelling of "Intriguing" for the Intriguing Filth task item in Mordor. As such, Daily Tasks is no longer recognizing this item.
Pineleaf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-10-2017, 10:34 AM  
ursa_major_prime
The Wary

Forum posts: 0
File comments: 1
Uploads: 0
Post Compliments, errors, and a request

First off - I love this plugin; I find it to be one of the most useful and helpful.

One error I keep getting when I type /dtn - Error: Missing Location (doesn't chuff me all that much as I have other work arounds within the plugin to assist with this)

My request: The rep-only option is perfect, and the junk option is of course a great opposite to that. However, the in-between items, not-rep, not-junk could use an option to be identified easily (i.e. /dtnr - daily tasks not rep) if the items don't provide rep I just want to sell them as I *only* use rep-only task items.

I was delighted to see this updated for the new task board locations in the homesteads and to account for the change in level requirements.

Keep up the good work and thank you!

UMP
ursa_major_prime is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-18-2017, 09:57 PM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 547
Uploads: 8
Re: Re: Re: Mordor tasks level 115

Quote:
Also I don't find the item in "DT_Data_FR.lua"
I haven't received any update for the French version, so it doesn't have the new task items. I thought you were trying to figure out how to update it. You'd need to copy the new items to the French version and then replace the names.
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-18-2017, 04:27 PM  
McCharle
The Wary

Forum posts: 0
File comments: 2
Uploads: 0
Re: Re: Mordor tasks level 115

Thank you for the reply.

I tried the 5 items on dtw :

- Obsidian Scale has no known task use. (Éclat d'obsidienne in French)
- Mysterious Ear has no known task use. (Mystérieuse oreille in French)
- Intruiging Filth* has no known task use. (Étrange saleté in French) *wrote like this in DT_Data.lua
- Curious Goo has no known task use. (Étrange sécrétion in French)

- when I try "Stony Skin", the error "...he Rings Online\Plugins\Vinny\DailyTasks\DT_Main.lua:202: attempt to compare number with string"

Also I don't find the item in "DT_Data_FR.lua"
McCharle is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-18-2017, 02:01 PM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 547
Uploads: 8
Re: Mordor tasks level 115

Quote:
But with Mordor tasks I encounter a problem :
- I have all the 5 items of the Ruins of Dingarth task board but /dt doesn't know them
You will need the corresponding item names in the data file before they will be recognized. Try dragging the 5 items into the box in the DT window so that it can detect the item ID and then it should tell you the corresponding names. Another way would be to list the usable items for a board there instead of the complete tasks.
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-18-2017, 12:49 PM  
McCharle
The Wary

Forum posts: 0
File comments: 2
Uploads: 0
Mordor tasks level 115

Hello,

with French LOTRO, I have made the modifications listed below I can now load and reload the plugins, thank you very much.

But with Mordor tasks I encounter a problem :
- I have all the 5 items of the Ruins of Dingarth task board but /dt doesn't know them
Quote:
DT: Backpack trophy items:
DT: Éclat d'obsidienne has no known task use.
DT: Étrange sécrétion has no known task use.
DT: Étrange saleté has no known task use.
DT: Fourreau d'épée orque has no known task use.
...he Rings Online\Plugins\Vinny\DailyTasks\DT_Main.lua:202: attempt to compare number with string
The last item, "Peaux Rugueuses" seems to be "Stoney Skins" make the error.
McCharle is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-12-2017, 02:19 PM  
Altair7
The Wary

Forum posts: 0
File comments: 16
Uploads: 0
Seems to be working now. Worked with Dor Amarth tasks in Mordor at least.
Altair7 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-11-2017, 01:29 PM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 547
Uploads: 8
Version 4.3.1

This is mainly the 4.3 fix which sets the minimum level required for Mordor tasks to 105 instead of 110.

Last edited by Vinny : 08-11-2017 at 01:29 PM.
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-10-2017, 04:56 PM  
Altair7
The Wary

Forum posts: 0
File comments: 16
Uploads: 0
/dtn ;loc not working in Udun Foothold and Haerondir

If I open the window with /dtw and click Check Nearest in Udun Foothold and Haerondir, or use /dtn ;loc, I get no trophies showing up even though I have trophies that can be turned in in my bags.

/dt works fine and shows the trophies as normal.

This is only a problem at the above two locations as far as I know (haven't travelled any further into Mordor yet).
Altair7 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-10-2017, 11:09 AM  
Garan
The Undying
 
Garan's Avatar
Interface Author - Click to view interfaces

Forum posts: 243
File comments: 724
Uploads: 19
Re: Re: Re: Re: ver. 4.3

Quote:
Originally Posted by Marmi
I used Notepad++ for editing, this bad file indeed contains '»' in first line (2nd byte), not sure when these additional 3 bytes were added at beginning of that file (upon uncompressing or editing). When I downloaded and uncompressed plugin manually system asked if files should be overwritten. Now I'm not sure I chosen Yes to all, there is slight chance I clicked something else...
Anyway after I moved entire folder and unzipped again it works. Thank you for your support. I'm only not sure if I can safely delete old/bad version (some plugins I use contain user data like Alt Inventory).
Glad you have it working

Notepad++ is fine for editing (I use it myself for my files that need non-ASCII characters) as long as you double check that the encoding, from the Encoding menu, is set as "Encode in UTF-8 without BOM" not just "Encode in UTF-8". I've had the encoding change on me in documents and never tracked down the reason, but it may have something to do with copy/paste from other applications.

As to plugin data, that is stored in files under the PluginData folder, not the Plugins folder, so deleting plugin source files won't remove any data or settings saved by the plugin. Of course, that also means that if the actual error was a corrupted data file, deleting the entire plugin source and re-installing wouldn't help, but fortunately that wasn't the case here.

Last edited by Garan : 08-10-2017 at 11:12 AM.
Garan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-10-2017, 06:06 AM  
marmi
The Wary

Forum posts: 4
File comments: 11
Uploads: 0
Re: Re: Re: ver. 4.3

Quote:
FWIW, the error message '=' expected near '»' indicates that the parser couldn't parse the file because of an unsupported character (which may not occur on the line reported). Double check that the file is encoded correctly as that is the most likely culprit for that specific error. Many text editors save UTF-8 encoding with BOM (Byte Order Mark) but the Lua interpreter needs them encoded as "UTF-8 without BOM" (or as ASCII if they don't contain any non-ASCII characters).

EDIT: I notice Marmi said he/she tried at some point editing line 143 - depending on what editor he/she used, that may have been what changed the encoding of the file. I'm not sure why a new install would not work, but I would recommend deleting the entire Vinny folder (to be sure nothing is read-only) and re-downloading.
I used Notepad++ for editing, this bad file indeed contains '»' in first line (2nd byte), not sure when these additional 3 bytes were added at beginning of that file (upon uncompressing or editing). When I downloaded and uncompressed plugin manually system asked if files should be overwritten. Now I'm not sure I chosen Yes to all, there is slight chance I clicked something else...
Anyway after I moved entire folder and unzipped again it works. Thank you for your support. I'm only not sure if I can safely delete old/bad version (some plugins I use contain user data like Alt Inventory).
marmi is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-09-2017, 03:27 PM  
Garan
The Undying
 
Garan's Avatar
Interface Author - Click to view interfaces

Forum posts: 243
File comments: 724
Uploads: 19
Re: Re: ver. 4.3

Quote:
Originally Posted by Vinny
The error message indicates that the error occurred on line 1 of DT_Data.lua, but that line should start with "--", which is a comment and the rest of the line should be ignored, so it sounds like the file isn't being extracted properly. How are you installing it? I recommend "Plugin Compendium" for quick, easy installs.
FWIW, the error message '=' expected near '»' indicates that the parser couldn't parse the file because of an unsupported character (which may not occur on the line reported). Double check that the file is encoded correctly as that is the most likely culprit for that specific error. Many text editors save UTF-8 encoding with BOM (Byte Order Mark) but the Lua interpreter needs them encoded as "UTF-8 without BOM" (or as ASCII if they don't contain any non-ASCII characters).

EDIT: I notice Marmi said he/she tried at some point editing line 143 - depending on what editor he/she used, that may have been what changed the encoding of the file. I'm not sure why a new install would not work, but I would recommend deleting the entire Vinny folder (to be sure nothing is read-only) and re-downloading.

Last edited by Garan : 08-09-2017 at 09:02 PM.
Garan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-09-2017, 02:25 PM  
marmi
The Wary

Forum posts: 4
File comments: 11
Uploads: 0
Re: Re: ver. 4.3

Quote:
The error message indicates that the error occurred on line 1 of DT_Data.lua, but that line should start with "--", which is a comment and the rest of the line should be ignored, so it sounds like the file isn't being extracted properly. How are you installing it? I recommend "Plugin Compendium" for quick, easy installs.
Yes, I'm using compendium. On 2nd try I unzipped files manually since plugin was already current version. My DT_Data.lua indeed starts with --.
So I moved whole Vinny folder to another place and uncompressed downloaded file again. Plugin works now, thank you.
Then I compared both folders and oddly enough DT_Data.lua content appeared to be identical in both cases (I used a tool from Total Commander), however version which doesn't work is larger by 3 bytes (67342 vs. 67339). Finally I opened that bigger file in hex editor and found that it actually begins with 3 bytes which aren't displayed in text editors.
Not sure what happened at start but at least I know why it didn't work.
Are there any user data in this plugin (maybe I should copy back some files from my original plugin)? It seems other files are the same in both copies, but just to be sure...
marmi is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-08-2017, 04:04 PM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 547
Uploads: 8
Re: ver. 4.3

Quote:
After upgrading to ver. 4.3 plugin doesn't load. Here is what I got in chat window:
...uments\The Lord of the Rings Online\Plugins\Vinny\DailyTasks\DT_Data.lua:1: '=' expected near '»'
...he Rings Online\Plugins\Vinny\DailyTasks\DT_Main.lua:18: Failed to import package "Vinny.DailyTasks.DT_Data".
The error message indicates that the error occurred on line 1 of DT_Data.lua, but that line should start with "--", which is a comment and the rest of the line should be ignored, so it sounds like the file isn't being extracted properly. How are you installing it? I recommend "Plugin Compendium" for quick, easy installs.
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 11:49 AM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | VGInterface | LoTROInterface | MMOInterface | Swtorui