Quantcast
VGInterface.com
Search Downloads


Go Back   LoTROInterface > LotRO Stand-Alone Plugins > Maps, coordinates & compasses


Post A Reply
Author Comments Comment Options
Unread 08-13-2015, 11:16 PM  
Garan
The Undying
 
Garan's Avatar
Interface Author - Click to view interfaces

Forum posts: 267
File comments: 772
Uploads: 19
Re: Re: Re: getting an error on load

UncleJed, I haven't been able to reproduce your particular issue yet. I'll post again when I have a better idea of what has happened and perhaps how to proceed.
Garan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-13-2015, 03:01 PM  
UncleJed
The Wary

Forum posts: 0
File comments: 4
Uploads: 0
Re: Re: getting an error on load

Quote:
Originally Posted by UncleJed
Hello! This looks like it has some awesome potential and I'm looking forward to checking it out. Unfortunately it's giving me an error when loading. Here is the exact text:
Loaded plugin "moormap".
MoorMap 1.29 by Garan loaded
...the Rings Online\Plugins\GaranStuff\MoorMap\Main.lua:5302: attempt to index field '?' (a nil value)

When I try to pull up the maps, I'm only getting the big overview map of the Ettenmoors and there's nothing in what appears to be in the drop-down at the top of the screen. So it would appear that the maps weren't indexed properly. Any thoughts?
Thanks!
UncleJed
It appears that the default data was not automatically processed when the plugin was first loaded. This can happen for a couple of reasons, the most common being that the user set one of the auxiliary plugins to load automatically. Please double check that you have not accidentally set one of the auxiliary plugins, MoorMapDefaults, MoorMapLoader, MoorMapTerminator or MMSearch to load automatically. Additionally, be sure that you are either automatically or manually only loading "MoorMap". Once you are sure you are manually loading MoorMap and not automatically loading any of the other plugins, open the plugin map, follow these steps to force a reload of the default data:

1) execute "/plugins unload" from the chat window to be sure no other plugin is interfering with the processing of defaults (assuming you're using an English client)
2) manually load the "MoorMap" plugin using the chat command "/plugins load moormap" (again assuming you're using an English client)
3) right click on the plugin map and click "Add Annotation" on the popup menu
4) In the Custom Annotation Maintenance window, click the button at the bottom center, "Reload Defaults"
5) After the defaults finish processing, the plugin should automatically reload and function properly

Today I did exactly as you suggested. I started by "unloading". Was successful. Then I loaded moormap using chat command line (the same way I had done it before). Yesterday, I noticed the little loading window that popped up had actually frozen in place at the point where it said "terminated", then it started throwing those errors (sorry - i should have iterated that originally).
Anyway, today after following your above steps, it appears that it completed loading the default maps, but it entered into an eternal loop of reloading them over and over again. so it would finish, but it appears that something triggered the plugin to reload itself constantly. I just did "/plugins unload" to end the cycle....which means I was unable to get to steps 3, 4, and 5.


Please answer a couple of questions so that I can try to identify the cause of this issue:
1) had you accidentally loaded any of the auxiliary plugins? (if "yes", you can ignore the rest of the questions) I don't think so. I was doing all of this manually and didn't load any of the dependents separately.
2) did you have a previous version of MoorMap? No - this is my first try.
3) what client language are you using, EN, DE or FR? EN
4) if this was your first installation of MoorMap, what operating system do you use? Windows 10
5) if this was your first installation of MoorMap, did you first try loading the map on a Freep or a Creep character? Freep - CORRECTION - was just regular player in the normal LOTRO game. i.e. NOT in Monster Play. I misunderstood what "FREEP" meant.

Please let me know whether reloading the defaults manually resolved your issue.

Thanks,
Garan

Thanks for you assistance, BTW!

Last edited by UncleJed : 08-13-2015 at 04:20 PM.
UncleJed is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-12-2015, 07:15 PM  
Garan
The Undying
 
Garan's Avatar
Interface Author - Click to view interfaces

Forum posts: 267
File comments: 772
Uploads: 19
Re: getting an error on load

Quote:
Originally Posted by UncleJed
Hello! This looks like it has some awesome potential and I'm looking forward to checking it out. Unfortunately it's giving me an error when loading. Here is the exact text:
Loaded plugin "moormap".
MoorMap 1.29 by Garan loaded
...the Rings Online\Plugins\GaranStuff\MoorMap\Main.lua:5302: attempt to index field '?' (a nil value)

When I try to pull up the maps, I'm only getting the big overview map of the Ettenmoors and there's nothing in what appears to be in the drop-down at the top of the screen. So it would appear that the maps weren't indexed properly. Any thoughts?
Thanks!
UncleJed
It appears that the default data was not automatically processed when the plugin was first loaded. This can happen for a couple of reasons, the most common being that the user set one of the auxiliary plugins to load automatically. Please double check that you have not accidentally set one of the auxiliary plugins, MoorMapDefaults, MoorMapLoader, MoorMapTerminator or MMSearch to load automatically. Additionally, be sure that you are either automatically or manually only loading "MoorMap". Once you are sure you are manually loading MoorMap and not automatically loading any of the other plugins, open the plugin map, follow these steps to force a reload of the default data:

1) execute "/plugins unload" from the chat window to be sure no other plugin is interfering with the processing of defaults (assuming you're using an English client)
2) manually load the "MoorMap" plugin using the chat command "/plugins load moormap" (again assuming you're using an English client)
3) right click on the plugin map and click "Add Annotation" on the popup menu
4) In the Custom Annotation Maintenance window, click the button at the bottom center, "Reload Defaults"
5) After the defaults finish processing, the plugin should automatically reload and function properly

Please answer a couple of questions so that I can try to identify the cause of this issue:
1) had you accidentally loaded any of the auxiliary plugins? (if "yes", you can ignore the rest of the questions)
2) did you have a previous version of MoorMap?
3) what client language are you using, EN, DE or FR?
4) if this was your first installation of MoorMap, what operating system do you use?
5) if this was your first installation of MoorMap, did you first try loading the map on a Freep or a Creep character?

Please let me know whether reloading the defaults manually resolved your issue.

Thanks,
Garan

Last edited by Garan : 08-12-2015 at 07:21 PM.
Garan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-12-2015, 06:31 PM  
UncleJed
The Wary

Forum posts: 0
File comments: 4
Uploads: 0
getting an error on load

Hello! This looks like it has some awesome potential and I'm looking forward to checking it out. Unfortunately it's giving me an error when loading. Here is the exact text:
Loaded plugin "moormap".
MoorMap 1.29 by Garan loaded
...the Rings Online\Plugins\GaranStuff\MoorMap\Main.lua:5302: attempt to index field '?' (a nil value)

When I try to pull up the maps, I'm only getting the big overview map of the Ettenmoors and there's nothing in what appears to be in the drop-down at the top of the screen. So it would appear that the maps weren't indexed properly. Any thoughts?
Thanks!
UncleJed
UncleJed is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-07-2015, 10:54 AM  
Illiani
The Wary
 
Illiani's Avatar

Forum posts: 0
File comments: 2
Uploads: 0
Just wanted to say thank you for all the work put into this mod, it has all but replaced the default map for me. Get quest data to appear in this and I'll never need to use the default map again!

But serious, thank you. <3
Illiani is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 06-23-2015, 05:59 AM  
Garan
The Undying
 
Garan's Avatar
Interface Author - Click to view interfaces

Forum posts: 267
File comments: 772
Uploads: 19
Ver 1.29 has the maps and default data for Eastern Gondor

Last edited by Garan : 06-23-2015 at 12:46 PM.
Garan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 06-20-2015, 11:13 AM  
Garan
The Undying
 
Garan's Avatar
Interface Author - Click to view interfaces

Forum posts: 267
File comments: 772
Uploads: 19
Re: Map Positioning

Quote:
Originally Posted by Earthsuit
Greets. Love this plugin, especially with the overlay capability. I've made a couple of them myself. So, thanks for not only writing this, but also for maintaining it.

I wonder if you could help me figure out how to specify the initial placement of the map. When I drag it to a location and open the options window, it shows the current left and top. However, when I click save, close the map, and reopen it, it opens at 0,0. The default I assume.

Is there another way to set this? A data file or something of the sort? You mention one in the defaults.lua:



Any help would be appreciated and thanks again.
I believe you have your graphics set to "Full Screen (Windowed)" mode. Unfortunately, Turbine never properly implemented this mode in Lua so it incorrectly reports the size of the screen to Lua causing the problem you are experiencing - basically, upon load the plugin attempts to adjust to the current screen size, adjusting the map top and left to make sure that the map still fits on screen if the user changed resolutions. I believe that if you go into your graphics settings, select "Windowed" mode, change the resolution to match the Full Screen resolution and then change back to "Full Screen (Windowed)" it might work as a workaround for this bug until Turbine fixes it correctly - it sort of works for me but the map still doesn't quite fill the screen at it's largest size so there's still a discrepancy and might not work properly in "Full Screen (Windowed)" for all users. I usually just play in Full Screen mode to avoid the whole issue.

EDIT:
FWIW, the settings referred to in the defaults.lua are map coordinates relative to the world map coordinates from /loc to determine the x,y coordinates of icons on the maps (each map has it's own scale and position relative to the N/S E/W axis of the region it is in). That note is basically just a reminder to myself for how to calculate the necessary coordinates when implementing new maps.

P.S. glad to hear that someone is making use of the Overlay functionality - I thought it was one of the most useful features I implemented but haven't heard from anyone else that actually made any Overlays - for which maps did you make Overlays and what features do you use them to implement?

Last edited by Garan : 06-20-2015 at 01:23 PM.
Garan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 06-20-2015, 10:28 AM  
Earthsuit
The Wary

Forum posts: 2
File comments: 20
Uploads: 0
Map Positioning

Greets. Love this plugin, especially with the overlay capability. I've made a couple of them myself. So, thanks for not only writing this, but also for maintaining it.

I wonder if you could help me figure out how to specify the initial placement of the map. When I drag it to a location and open the options window, it shows the current left and top. However, when I click save, close the map, and reopen it, it opens at 0,0. The default I assume.

Is there another way to set this? A data file or something of the sort? You mention one in the defaults.lua:

Quote:
-- HFactor and HOffset are used in the conversion from map coordinates to pixels: X=Height*HFactor+HOffset will convert coordinate "Height" to pixel "X"
-- -- the excel spreadsheet "MoorMap Data.xls" contains the calculated values using two points, one at top left of map, the other at bottom right of map.
-- -- source columns: B=top left NS, C=top left world EW, D=top left pixel world X, E=top left pixel Y, F=bottom right NS, G=bottom right world EW, H=bottom right pixel world X, I=bottom right pixel Y
-- -- calculated columns: J=hFactor, M=hOffset, N=wFactor, Q=wOffset
Any help would be appreciated and thanks again.
Earthsuit is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 02-18-2015, 04:29 AM  
Arctic
The Wary

Forum posts: 0
File comments: 2
Uploads: 0
Re: Re: overlay doesn't work for me

Garan,
Thank you for very prompt reply.
There were no error mesages.
And
"... click the Reload Defaults button at the bottom center" worked!
You can advise this to other guys with similar problem.

Your plugin is awesome!

Last edited by Arctic : 02-18-2015 at 04:31 AM.
Arctic is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 02-17-2015, 02:31 PM  
Garan
The Undying
 
Garan's Avatar
Interface Author - Click to view interfaces

Forum posts: 267
File comments: 772
Uploads: 19
Re: overlay doesn't work for me

Quote:
Originally Posted by Arctic
very cool plugin. One of the best I've seen for Lotro.

But I have problem. The reason I installed it was overlays with deed maps. But overlays for some weird reason are not working for me. I mean preinstalled overlays from BDD do not show up at all. No clickable sign appear on the map. I checked with Bree, Barrow-Downs etc. I tried to install plugin with System's Plugin Manager, tried to deinstall and install manually, tried to unload all other plugins like Palantir and Buffbars, even tried to manually specify path in overlay button dialogue - all in vain. Spent few hours checking LUA scripts in package etc.

I have no idea why it's not working for me. Overlays with deed maps is like 70-80 per cent of my motivation for this plugin.

Everything else is working fine.
Any further advice?
First, when the plugin loads are there any error messages? If not, what is the exact text of the message saying the plugin is loaded?

If there are no errors and the message reads exactly "MoorMap 1.28 by Garan loaded" then you are on the right version. If the words "Select Overlay" appears to the right of the map selection list, that is where you click to show the overlay list. If the words are not appearing, the next thing to try is forcing a reload of the default data, including the BDD overlays. Load the plugin and display the map, right click on the map and select Add Annotation from the popup menu. In the Custom Annotations Maintenance window, click the Reload Defaults button at the bottom center. Once the plugin is done reloading defaults it should redisplay the map. You should see the words "Select Overlay" next to the map selection list. Note, not all maps have default overlays so pick one like Breeland to be sure. If the words show, just click there to select the overlay(s) to display. A pop-up list will appear with checkboxes at the left, just click an entry on the list to toggle that overlay.

If you have reloaded default data and "Select Overlay" still does not appear next to the map selection list for Breeland, let me know and we can try debugging this further.

Last edited by Garan : 02-17-2015 at 02:33 PM.
Garan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 02-17-2015, 12:14 PM  
Arctic
The Wary

Forum posts: 0
File comments: 2
Uploads: 0
overlay doesn't work for me

very cool plugin. One of the best I've seen for Lotro.

But I have problem. The reason I installed it was overlays with deed maps. But overlays for some weird reason are not working for me. I mean preinstalled overlays from BDD do not show up at all. No clickable sign appear on the map. I checked with Bree, Barrow-Downs etc. I tried to install plugin with System's Plugin Manager, tried to deinstall and install manually, tried to unload all other plugins like Palantir and Buffbars, even tried to manually specify path in overlay button dialogue - all in vain. Spent few hours checking LUA scripts in package etc.

I have no idea why it's not working for me. Overlays with deed maps is like 70-80 per cent of my motivation for this plugin.

Everything else is working fine.
Any further advice?

Last edited by Arctic : 02-17-2015 at 12:15 PM.
Arctic is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 02-08-2015, 06:35 AM  
Elrothiel
The Wary

Forum posts: 0
File comments: 11
Uploads: 0
very nice plugin ty very much makes it a lot easier great job on the plugin to
Elrothiel is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 02-01-2015, 10:51 AM  
Imiona
The Wary
 
Imiona's Avatar

Forum posts: 3
File comments: 20
Uploads: 0
Thx
Imiona is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 02-01-2015, 10:42 AM  
Garan
The Undying
 
Garan's Avatar
Interface Author - Click to view interfaces

Forum posts: 267
File comments: 772
Uploads: 19
Quote:
Originally Posted by Imiona
MoorMap doesnt show Quest Locations, do i miss something here?^^
MoorMap shows Points of Interest and NPCs (and some quest items) but does not show quest locations such as the in-game quest tracker since that information is not exposed to Lua. Unfortunately, with RoI, Turbine started including dynamic locations for NPCs so many of them are only shown at one of their possible locations - the state of quests and the NPC locations are not exposed to Lua so the positions are wherever the NPCs were encountered when I was capturing locations.

Since the quest data is not exposed, there is no way to indicate your current quest locations so you may need to use the search feature to find NPCs or Points of Interest by name. There are two search features, one for the current map (silver magnifier icon) which uses a filter to show the names of matching map points on the current map and the global search (gold magnifier icon) which takes a little longer but searches all maps for a name.
Garan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 02-01-2015, 10:01 AM  
Imiona
The Wary
 
Imiona's Avatar

Forum posts: 3
File comments: 20
Uploads: 0
MoorMap doesnt show Quest Locations, do i miss something here?^^
Imiona is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 10:08 PM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | VGInterface | LoTROInterface | MMOInterface | Swtorui