Quantcast
VGInterface.com
Search Downloads


Go Back   LoTROInterface > LotRO Stand-Alone Plugins > Maps, coordinates & compasses


Post A Reply
Author Comments Comment Options
Unread 08-11-2015, 04:54 AM  
Thurallor
The Undying
 
Thurallor's Avatar
Interface Author - Click to view interfaces

Forum posts: 136
File comments: 183
Uploads: 12
This plugin has a bug in it that prevents it from working if it has not previously created the settings file (which is always true the first time you run it on a new machine). It must have been introduced after the author and most users created their settings file with a previous version of the plugin.

You can fix the problem yourself by editing the file RadicusPlugins/StableGuy/Window.lua. Change the third line in that file from
Code:
local Settings = Turbine.PluginData.Load(Turbine.DataScope.Character, "StableGuySettings");
to
Code:
local Settings = Turbine.PluginData.Load(Turbine.DataScope.Character, "StableGuySettings") or {};
Uman's solution below will also work, but it forces the "VIP" checkbox to always be checked on startup.

Last edited by Thurallor : 08-11-2015 at 05:01 AM.
Thurallor is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-04-2015, 08:07 AM  
Illiani
The Wary
 
Illiani's Avatar

Forum posts: 0
File comments: 2
Uploads: 0
Lightbulb Known Stables Idea

Had an idea for the issue of removing unknown stables from the route list.

Have a list of binary variables comprising all stable masters in the game. Unknown False, known True. Allow users to access a tick box list (grouped by region & zone for ease of use), this is to allow manual input of known stables. An option should exist for users to use a single box to select all stables within a zone, or region.

Have an tick box for uses to specify whether they wish the route to contain unknown stables. If so the route is formed as it is currently, with unknown stables marked in some way (greyed out, for example). If the user specifies not to include unknown stables the route is formed from only those known stables, perhaps including a message dictating how far away (as the crow flies) the final horse taxi will end up from the objective.

The route finder uses the variables defined earlier to determine whether a route is known, or unknown. Furthermore, when a message occurs in the chat to specify that a new route has been discovered, the plugin uses /loc to determine where the character is and references that to the coords of the stable guy (within, say 5% variance to allow for players to be a bit off target).

Issues: requires the plugin to monitor chat; requires the cords for all stable guys to be discovered and noted prior to release; initially requires a lot of user input to set up for non-newly created characters; non-elegent work around.

Positives: solves the issue it set out to solve; while requires a lot of initial work by writer, later stables can be added with limited difficulty & work.

Let me know what you think, I'd be willing to gather the coords for the stable guys and build the reference list, so long as you can tell me what format it needs to take.
Illiani is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 06-09-2015, 12:36 PM  
Iollan
The Wary

Forum posts: 0
File comments: 4
Uploads: 0
Re: Workaround

Thanks for this workaround Uman, it's worked brilliantly.

++++++++++
If you see these messages:

...s Online\Plugins\RadicusPlugins\StableGuy\Window.lua :159: attempt to index local 'Settings' (a nil value)
...ngs Online\Plugins\RadicusPlugins\StableGuy\Main.lua:1 1: Failed to import package "RadicusPlugins.StableGuy.Window".

One workaround is to edit the window.lua file (in the RadicusPlugins/StableGuy folder) and change this if statement (lines 159-161)

if Settings["VIPState"]==true then
wStableGuy.checkboxVIP:SetChecked(true);
end

to just

wStableGuy.checkboxVIP:SetChecked(true);

It's not within my expertise to explain why detecting the VIPState fails. Maybe someone smarter knows.
Iollan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 03-16-2015, 07:08 PM  
IceWarrior10
The Wary

Forum posts: 0
File comments: 1
Uploads: 0
Workaround

Hi, I don't know lua but i believe this works

if Settings~=nil then
if Settings["VIPState"]==true then
wStableGuy.checkboxVIP:SetChecked(true);
end
end

Last edited by IceWarrior10 : 03-16-2015 at 07:10 PM.
IceWarrior10 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 02-26-2015, 12:59 PM  
Uman
The Wary

Forum posts: 0
File comments: 1
Uploads: 0
Workaround

If you see these messages:

...s Online\Plugins\RadicusPlugins\StableGuy\Window.lua :159: attempt to index local 'Settings' (a nil value)
...ngs Online\Plugins\RadicusPlugins\StableGuy\Main.lua:1 1: Failed to import package "RadicusPlugins.StableGuy.Window".

One workaround is to edit the window.lua file (in the RadicusPlugins/StableGuy folder) and change this if statement (lines 159-161)

if Settings["VIPState"]==true then
wStableGuy.checkboxVIP:SetChecked(true);
end

to just

wStableGuy.checkboxVIP:SetChecked(true);

It's not within my expertise to explain why detecting the VIPState fails. Maybe someone smarter knows.
Uman is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-26-2015, 01:53 PM  
Ordegar
The Wary

Forum posts: 2
File comments: 4
Uploads: 0
Quote:
I'm assuming you mean travel locations reference.

http://www.lotrointerface.com/downlo...nfo.php?id=524

and thanks, I will remove this one and and install TLR.
Yes, that's the one.
Ordegar is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-26-2015, 08:14 AM  
shroder300
The Wary
 
shroder300's Avatar

Forum posts: 0
File comments: 3
Uploads: 0
I'm assuming you mean travel locations reference.

http://www.lotrointerface.com/downlo...nfo.php?id=524

and thanks, I will remove this one and and install TLR.
shroder300 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-24-2015, 02:28 PM  
Ordegar
The Wary

Forum posts: 2
File comments: 4
Uploads: 0
Re: Re: Re: Error on load

Quote:
I also get an error. I tried manual install and via the Compendium installer. My log has this error (it looks like it's trying to open settings but I've never loaded a previous version of Stableguy so there is no settings to load?):

Code:
...s Online\Plugins\RadicusPlugins\StableGuy\Window.lua:159: attempt to index local 'Settings' (a nil value)
...ngs Online\Plugins\RadicusPlugins\StableGuy\Main.lua:11: Failed to import package "RadicusPlugins.StableGuy.Window".
I have same problem. has there been a fix yet?
No. It looks like Radicus is no longer maintaining this. I'm using the Travel Reference addon instead; which is similar in concept to this but has some nice features such as taking into consideration what discounts you may have, and what locations you have unlocked via reputation; and whether you are high enough level to use quick travel to a location.
Ordegar is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-24-2015, 02:20 PM  
shroder300
The Wary
 
shroder300's Avatar

Forum posts: 0
File comments: 3
Uploads: 0
Re: Re: Error on load

I also get an error. I tried manual install and via the Compendium installer. My log has this error (it looks like it's trying to open settings but I've never loaded a previous version of Stableguy so there is no settings to load?):

Code:
...s Online\Plugins\RadicusPlugins\StableGuy\Window.lua:159: attempt to index local 'Settings' (a nil value)
...ngs Online\Plugins\RadicusPlugins\StableGuy\Main.lua:11: Failed to import package "RadicusPlugins.StableGuy.Window".
I have same problem. has there been a fix yet?
shroder300 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-03-2015, 11:34 PM  
Ordegar
The Wary

Forum posts: 2
File comments: 4
Uploads: 0
Re: Error on load

Quote:
When I try to load StableGuy, I get an error in Window.lua line 159 "attempt to index local 'Settings' (a nil value)". Any idea why that is (or how to fix it)?
I also get an error. I tried manual install and via the Compendium installer. My log has this error (it looks like it's trying to open settings but I've never loaded a previous version of Stableguy so there is no settings to load?):

Code:
...s Online\Plugins\RadicusPlugins\StableGuy\Window.lua:159: attempt to index local 'Settings' (a nil value)
...ngs Online\Plugins\RadicusPlugins\StableGuy\Main.lua:11: Failed to import package "RadicusPlugins.StableGuy.Window".

Last edited by Ordegar : 01-05-2015 at 05:30 PM.
Ordegar is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-27-2014, 01:31 AM  
wilcoxon
The Wary

Forum posts: 0
File comments: 1
Uploads: 0
Error on load

When I try to load StableGuy, I get an error in Window.lua line 159 "attempt to index local 'Settings' (a nil value)". Any idea why that is (or how to fix it)?
wilcoxon is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 04-21-2014, 04:36 AM  
Hyoss
The Undying
 
Hyoss's Avatar
Interface Author - Click to view interfaces

Forum posts: 68
File comments: 154
Uploads: 1
Wanted to give you a thanks, your plugin is much appreciated.
Hyoss is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-30-2012, 06:12 AM  
Radicus
The Undefeated
 
Radicus's Avatar
Interface Author - Click to view interfaces

Forum posts: 5
File comments: 15
Uploads: 3
Must have been tired! StableGuy correctly uploaded this time.
Radicus is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-29-2012, 12:56 PM  
Ralgel
The Wary
 
Ralgel's Avatar

Forum posts: 0
File comments: 8
Uploads: 0
The latest version that is posted here is SocialGuy, not StableGuy
Ralgel is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-14-2012, 05:47 PM  
Garan
The Undying
 
Garan's Avatar
Interface Author - Click to view interfaces

Forum posts: 245
File comments: 725
Uploads: 19
Quote:
Originally Posted by Tegalad
Does anyone else have the problem where the button stops working after a while? I don't know yet how you can reproduce it, but after a while when I click on the button nothing is happening and I cant even move the button anymore. Restarting the plugin doesn't help (I must restart the game to make it work again)...
The button is most likely getting stuck under a transparent portion of another window, such as the map compass or another plugin, and when that window is brought to the front, the button can no longer be accessed. I don't use this plugin, but if the button can be moved, try moving it to another location and see if the problem goes away. If it can't be moved, then try using Ctrl+\ to see if a built-in UI element is the problem and you can then move that.

Last edited by Garan : 10-14-2012 at 05:49 PM.
Garan is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 01:37 AM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | VGInterface | LoTROInterface | MMOInterface | Swtorui