Quantcast
VGInterface.com
Search Downloads


Go Back   LoTROInterface > LotRO Patches

Category: LotRO PatchesFilterBag
This file is a Patch for FilterBag by Betsiel. You must have that installed before this Patch will work.
Interface Information
Download
How do I install this? (FAQ)
Name: FilterBag   Popular!
Author:
Date: 12-02-2010 02:03 PM
Size: 34.45 Kb
Version: 1.7b
Rate File: 5 out of 5 with 4 votes  
Pictures
Click to enlarge 

Views: 0
Size: 45.41 Kb
Dimensions: 407 x 364
FilterBag
 
Description
Version 1.7b : bug fix release:
I believe I fixed issues with loading plugin "for the first time".
Created a lot of workarounds to combat overload behavior, because to many events fire when items are auto-moved during sort & load, but it still causes slowdown while in progress. Will add option to minimize Onebag window while reordering items in next update or empty the window while its happening. Also trying to hold major item movements in the bags while sorting, but still not advisable to do anything while sort or load is in progress.
Made some temporary fixes to show some of the "disapearing" items when items are moved in or out of bags. None of these items are gone, just not visible due Turbine Lua API improper behavior.

Version 1.7 - November patch update:
Lua API compatibility fixes; plugin's title window text should now update when number of items changes ; other minor modifications.
Please use Save feature, to make sure you can come back to the way items were in your bags before using Sort.

History:
introduced version 1.5
Added save & load bags arrangement feature and altered sort of items by quality & category.
Fixed a lot of various bugs. added special error handling to avoid the dreaded lost item situation.
Also made plugin future update compatible.

Updated to version 1.6 :
Cleaned up categories for sorting (armor, jewellery & etc).
Added options feature (type /filterbag options), that allows for sortiing in just 1 of 5 combined bags (15 items); and sorting in reversed order.
Fixed - version 1.6b - bug fixes for 1.6;
added options button (copied from GaranStuff);
eliminated unnecessary dependancies & included required ones into the archive.

Updated to version 1.6c
further clean up of sort categories, most items from the same set should be grouped together now;
sort & save might take slightly longer now, because its doing more thorough job.
have changed bound behavior of bag 1, 2, 3 & 4 buttons to open those individual bags when Big combined bag (FilterBag) window is closed. FilterBag window is now only toggled (opened/closed) by pressing bag 5 button or key bound to open all the bags (by default 'I')

Version 1.6d - bug fix release.
added ability to load Alt Inventory from option window.

Version 1.6e - added chat command options: /sort, /save, /load ; both save & load support save file name. few minor adjustments.
Archive List (Old Versions)
File Name
Version
Size
Author
Date
1.7a
33.45 Kb
pgmatg
11-30-2010 07:44 PM
1.7
33.70 Kb
pgmatg
11-30-2010 04:05 PM
1.6b
24.65 Kb
pgmatg
11-12-2010 07:23 PM
1.6a
19.45 Kb
pgmatg
11-12-2010 01:59 PM
1.6
19.14 Kb
pgmatg
11-12-2010 12:01 AM
1.5b
6.90 Kb
pgmatg
11-10-2010 05:14 PM
File Statistics
User Rating:
5 out of 5 with 4 votes
Downloads: 8709
Views: 17577
Favorites: 6
Uploaded By:
 
Last Modified: N/A

View Pictures. Download Now! Post A Comment


Post A Reply
Author Comments Comment Options
Unread 12-09-2010, 05:21 PM  
Kaneco
The Wary

Forum posts: 0
File comments: 6
Uploads: 0
Not working with turbine libraries from Dec 2
Kaneco is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-09-2010, 04:51 AM  
Sasco
The Wary
 
Sasco's Avatar

Forum posts: 2
File comments: 11
Uploads: 0
Thanks for making this plugin, really enjoy the functionality of it

Having some issues recently though, with the latest 1.7:
Sometimes items just don't show up that I have looted or unequiped etc, I have to turn off the plugin to see the items in my bags and turn it on again, anyway to stop this from happening?

Cheers
Sasco is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-08-2010, 05:13 AM  
hobi
The Wary

Forum posts: 0
File comments: 10
Uploads: 0
Same problem is when you restack items, they wont show up.
hobi is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-08-2010, 04:57 AM  
hobi
The Wary

Forum posts: 0
File comments: 10
Uploads: 0
I also get error like ...Online\Plugins\Betsiel\FilterBag\FilterBagWindo w.lua:493: attempt to index global 'DragItem' (a nil value) if i get items from bank.
Most of time, when i get items from mail they dont show up in the bag before i restart the plugin.
hobi is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-04-2010, 05:22 PM  
faldiin
The Undefeated

Forum posts: 6
File comments: 11
Uploads: 0
Error on Bank

2 issues I have found. I get the following when dragging from teh Bank. I am also getting an issue that we I equip items they dont show up in the bag anymore. I have to reload the plugins.


...Online\Plugins\Betsiel\FilterBag\FilterBagWindo w.lua:493: attempt to index global 'DragItem' (a nil value)


Faldiin
faldiin is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-03-2010, 12:29 AM  
faldiin
The Undefeated

Forum posts: 6
File comments: 11
Uploads: 0
Turbine Folder

I have to delete your turbine folder when I update. It breaks all my plugins. With your new update everything is working minus Turbine folder. Dont know why but glad to be working again. GL.


Faldiin
faldiin is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-02-2010, 02:00 PM  
pgmatg
The Wary
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 29
Uploads: 2
Sorry for no replying earlier, kinda tired & pissed off, because spend quite a long time trying to debug various problems prompted by the patch.
I believe I fixed issues with loading plugin "for the first time".
Created a lot of workarounds to combat overload behavior, because to many events fire when items are auto-moved during sort & load, but it will still cause slowdown while in progress. Will add option to minimize Onebag window while reordering items in next update or empty the window while its happening. Also trying to hold major item movements in the bags while sorting, but still not advisable to do anything while sort or load is in progress.
Made some temporary fixes to show some of the "disapearing" items when items are moved in or out of bags. None of these items are gone, just not visible due Turbine Lua API improper behavior.
There are definitely bugs in current Lua API Backpack implementation:
Items don't get updated properly when items are moved from & to bags inventory, like when item is equiped or drag & droped from character screen or vault.
There is also seem to be improper event firing when items are moved in, into or out of inventory.
The above misbehavior makes item management plugins to malfunction for most external (character, vault, shortcut) to internal (bags) manipulations.
We really need some kind of fix or workaround from Turbine devs for this issue in order for me to make any meaningful modification.
pgmatg is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-01-2010, 12:38 PM  
Temil2006
The Unscathed
Interface Author - Click to view interfaces

Forum posts: 17
File comments: 19
Uploads: 2
ok ok ok .. here is a full break down of have I was able to get this plugin to work, all the way up to the newest version.. I'm sure there is probably other ways to do it, but now that i have it working and in place.. I'm not touching it .. if it's not broke currently, i'm not fixing it.. lol
  1. install the original plugin v1.04a
  2. install patch v1.6e
  3. start the game, start the plugin, make sure it loads, close the game completely
  4. install patch v1.7a
  5. start the game, start the plugin, goto option, make sure it says "1.7" .. close the game, you are done

there seems to be some issues with going strait to 1.7a, so you have to make a small jump in between. I can only assume it's something within the setup/config of this plugin, but i'm just guessing.. reason I say this is because if you goto 1.7a, then try to go back to 1.6e, the plugin still shows 1.7 installed, which I think is pulling from the setings, and if there are setting differences, then I can see issues there.

((EDIT:
well, found another issue (not sure if this is a problem with this script or another one).. basicly, the FilterBag and AltInventory are brutaly fighting over the sorting of items. If you have an issue with items not moving to another slot in the bag, or with items not showing at all, make sure you dont have AltInventory plugin loaded, that one seems to be conflicting with this plugin. Without the AltInventory loaded, everything works perfectly.. (which I find odd, only because there is an option to load AltInventory from within this plugin) .. anyways, that's what i found out at least .. I'll keep on testing things to make sure all is working.

((EDIT2:
another issue, you can't equip items from the plugin. If you do, it still shows in the plugin and items dont show correctly in there untill you reload the plugin.

((EDIT3:
the game Devs really screwed us over this time around with all these changes, which in return cause all these problems . .I have another issue, and this one is a really problem, Locked up my entire PC, had to do a hard reset..
My inventory was all the way full except for 2 slots (not sure if the "close to full" maters, so I'm including that info) .. I hit sort, and everything locked up.. it was sorting the items, saw it doing 3-4 at a time, but PC, game, etc .. it all was chopy as can be during this. When it completed (45secs later give or take) it seemed to be OK, I tried to move, and everytime i moved it seemed to try and sort the inventory again, locking up the PC, etc.. into a constant loop for some reason. So, be cautious of the Sort key for now.. if yours take along time to sort, stop and restart the plugin.
On a side note, if this is going to be a major issue with sorting, maybe the plugin can follow the example that AltInventory does? It doesn't acualy SORT anything, it just lists it in a sort order. .but it doesnt resort the items in the bags, which is what FilterBags seems to be doing. Just an idea

Last edited by Temil2006 : 12-01-2010 at 03:46 PM.
Temil2006 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-01-2010, 12:26 PM  
Temil2006
The Unscathed
Interface Author - Click to view interfaces

Forum posts: 17
File comments: 19
Uploads: 2
Code:
...Plugins\Betsiel\FilterBag\FilterBagOptionsWindow.lua:127: attempt to index global 'altinv' (a nil value)
geting this error when clicking on "load AltInv" .. do you need to have the AltInventory plugin installed, and runing? or just installed? or not installed at all? ..for this feature?
Temil2006 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-01-2010, 12:20 PM  
Temil2006
The Unscathed
Interface Author - Click to view interfaces

Forum posts: 17
File comments: 19
Uploads: 2
Quote:
Temil, I have completed the 4 step repair but I still receive the same 3 error messages which result in the addon not loading.

"\Plugins\Betsiel\FilterBag\FilterBagWindow.lua:71 : attempt to index global 'settings' (a nil value)
\Plugins\Betsiel\FilterBag\__init__.lua:5: Failed to import package "Betsiel.FilterBag.FilterBagWindow".
\Plugins\Betsiel\FilterBag\Main.lua:4: Failed to import package "Betsiel.FilterBag".

I hope this helps in the debug process as i'm not very knowledgeable in scripting.
ok, so I was a little off (not by much) on my steps .. I deleted ALL of my plugins, and started from scratch. Here is how i got it working.. (keep in mind, the incrimenting number of slots doesn't increase it seems in this version/steps, but at least the bags seem to work)
  1. download v1.04a and extract to plugins folder .. http://www.lotrointerface.com/downlo...FilterBag.html
  2. download v1.6e and extract that to the plugins folder, overwriting files .. http://www.lotrointerface.com/downloads/info460.html
  3. start plugin, let me know if that works.


((EDIT::
I'm debating if that 1.6e is truly 1.6e.. if you load the plugin, it will say "1.7" on the options screen, which seems weird, unless the version was labeled wrong in the zip file, or the zips are all geted messed up (which would explain why so many people are having so many issues)
Also, keep in mind that those 3 errors are also the same exact 3 errors that you get when runing the 1.04a version, so again, maybe the zips are geting mixed up somewhere between being sent to the server, and them being downloaded by us. who knows?

Last edited by Temil2006 : 12-01-2010 at 12:23 PM.
Temil2006 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-01-2010, 11:31 AM  
Burr
The Wary
 
Burr's Avatar

Forum posts: 0
File comments: 3
Uploads: 0
Temil, I have completed the 4 step repair but I still receive the same 3 error messages which result in the addon not loading.

"\Plugins\Betsiel\FilterBag\FilterBagWindow.lua:71 : attempt to index global 'settings' (a nil value)
\Plugins\Betsiel\FilterBag\__init__.lua:5: Failed to import package "Betsiel.FilterBag.FilterBagWindow".
\Plugins\Betsiel\FilterBag\Main.lua:4: Failed to import package "Betsiel.FilterBag".

I hope this helps in the debug process as i'm not very knowledgeable in scripting.
Burr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-01-2010, 09:38 AM  
Temil2006
The Unscathed
Interface Author - Click to view interfaces

Forum posts: 17
File comments: 19
Uploads: 2
Quote:
I am also getting the same error as "Lichbane" and will not load. I deleted the old "save-data" and the old version before installing the 1.7a version.
I was able to get this working by doing the following steps..
  1. delete all the savedata for this plugin, and the plugin it's self
  2. download the original 1.4 version of this plugin, and copy that to the plugins folder first
  3. then down and copy the newest "patch" into the same plugin folder, overwriting the files.
  4. launch plugin, (I didn't get error then)

I'm not sure, but I think maybe are you not puting the original plugin in place first? it's stated in the info that the original is required, as this is a patch, not a standalone.

That all being said, even after doing all this, I did find one issue "after" you restart the game. After you restart the game, and then load this plugin back up, you can't seem to move any of the items around. The items are being moved, within the coding, I can tell because if you restart only the plugin, the items are in there NEW locations, but if you don't relaunch the plugin, then you will not see the items after moving them.
It also seems that any new items aren't being recorded to the plugin either, except for after relauch, they will be picked up, but again no new items will be reconized. (if that all makes since.)

(EDIT::
oh, and if you try to do an incrimental upgrade, meaning 1.4, 1.6, 1.6a, 1.7, 1.7a -- coping the new files into the patch folder, and replacing the one ones, the plugin will lockup in a major memory loop when you try to SORT. So, not recomened to do incrimental upgrades. Best to try and to a 1.4 to 1.7a strait, nothing in between --- heading out to work now, I'll test out 1.6 later, and see if that gives any different results)

Last edited by Temil2006 : 12-01-2010 at 09:41 AM.
Temil2006 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-01-2010, 04:28 AM  
Burr
The Wary
 
Burr's Avatar

Forum posts: 0
File comments: 3
Uploads: 0
I am also getting the same error as "Lichbane" and will not load. I deleted the old "save-data" and the old version before installing the 1.7a version.
Burr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-01-2010, 02:50 AM  
Lichbane
Premium Member
 
Lichbane's Avatar
Premium Member

Forum posts: 1
File comments: 31
Uploads: 0
Yup. Loaded 1.7a and get

Quote:
\Plugins\Betsiel\FilterBag\FilterBagWindow.lua:71: attempt to index global 'settings' (a nil value)
\Plugins\Betsiel\FilterBag\__init__.lua:5: Failed to import package "Betsiel.FilterBag.FilterBagWindow".
\Plugins\Betsiel\FilterBag\Main.lua:4: Failed to import package "Betsiel.FilterBag".
Lichbane is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-01-2010, 02:06 AM  
Hazado
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 10
File comments: 21
Uploads: 1
Starting with a fresh load of Betsiel 1.7a you get three errors and it wont load

Fresh load = no plugindata and no previous version of betsiel installed
Hazado is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 03:00 AM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | VGInterface | LoTROInterface | MMOInterface | Swtorui