Quantcast
VGInterface.com
Search Downloads


Go Back   LoTROInterface > LotRO Stand-Alone Plugins > Other


Post A Reply
Author Comments Comment Options
Unread 01-12-2011, 01:58 PM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 538
Uploads: 8
Re: inventory items counting bug

Quote:
I think I found small bug. It's connected with inventory items count.
Yes, I've run into this also, but it is a bug in Turbine's API. New items added to the inventory don't always show up in the API.

To prove that it isn't DT, unload and reload DT and now both stacks will be visible.
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-12-2011, 01:51 PM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 538
Uploads: 8
Re: Directory problems

Quote:
1) DailyTasks did not load and did not appear in the /plugins list
The .plugin file is included in the .zip file. Perhaps you just forgot to extract it?
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-12-2011, 01:48 PM  
Binori
The Wary

Forum posts: 0
File comments: 5
Uploads: 0
inventory items counting bug

Hi Vinny,

First of all thank you very much for this plugin. I use it every day! It's my favourite

I think I found small bug. It's connected with inventory items count.

How to test the bug?
Take some multiple items. Split them into 2 groups where one group will have <10 number of items.
Then execute command:
/dtc <location>

You will see that result returned by plugin depends on what item group will be find first.

See pictures which will explain all (I hope). I use plugin version 1.2.1
Binori is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-12-2011, 09:17 AM  
TimeStamp
The Wary

Forum posts: 3
File comments: 1
Uploads: 0
Directory problems

I'm on Windoze 7

I unzipped the files and now have .../The Lord of the Rings Online/Plugins/MyPlugins/DailyTasks

1) DailyTasks did not load and did not appear in the /plugins list

2) It did not load or appear in the /plugins list, until I created the following xml file in the MyPlugins directory (The format for which I borrowed from another plugin which DOES load)

Code:
<?xml version="1.0"?>
<Plugin>
	<Information>
		<Name>DailyTasks</Name>
		<Author>Vinny</Author>
		<Version>1.3</Version>
	</Information>
	<Package>MyPlugins.DailyTasks.DT_Main</Package>
</Plugin>
Now, DailyTasks appears in the /plugins list but will not load. It give a whole bunch of messages about Turbine.UI.Extensions and etc etc.

Apparently I have to load that.
SO... I got that from the Turbine boards and now (with the xml file I created) it seems to work.

Last edited by TimeStamp : 01-12-2011 at 09:37 AM.
TimeStamp is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-12-2011, 03:57 AM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 538
Uploads: 8
Smile Version 1.3

I've posted a new version that includes some basic windowed functionality. You can now click on some buttons instead of typing commands. I still need to add menu selections for Filters and Locations. I've also made a few corrections.

Try it out and suggest any ideas you have for more features.
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-10-2011, 02:10 PM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 538
Uploads: 8
Quote:
New Problem:
2) only gives me 1/ x even if I have more than one item in inventory. Is this right or a bug?
This is right, because its only looking at the supplied name and not at the inventory. Only the "1)" looks at inventory and "3)" uses whatever count is in the link.
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-10-2011, 06:22 AM  
GoldenDiablo
The Wary

Forum posts: 0
File comments: 7
Uploads: 0
Quote:
Have you tried to encode umlauts like this:
Code:
ä	\195\164
Ä	\195\132
ö	\195\182
Ö	\195\150
ü	\195\188
Ü	\195\156
ß	\195\159
Ok, this works really nice.

Now I get the following output for

"Geh\195\164rteter Panzer"

1) DT: 4/ 8 [Gehärteter Panzer], 36-40 @ Tinnudir(WA)
2) DT: 1/ 8 [Gehärteter Panzer], 36-40 @ Tinnudir(WA)
3) DT: 4/ 8 [Gehärteter Panzer], 36-40 @ Tinnudir(WA)

So to encode umlauts seems to solve the problem, thanks!

New Problem:
2) only gives me 1/ x even if I have more than one item in inventory. Is this right or a bug?
GoldenDiablo is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-10-2011, 06:13 AM  
GoldenDiablo
The Wary

Forum posts: 0
File comments: 7
Uploads: 0
Quote:
First, I need to know if the problem occurs in all of these cases:
1) /dt (listing items in inventory)
2) /dt <name> (typing the item name on the command line)
3) /dt <link> (Using Ctrl-right-click on the item)

In all but the last case the function DT_Find is called to locate the data entry and it forces the names to upper case for the comparison. I suspect that is where the problem occurs. You might see if lower case works better.
For example I use "Gehärteter Panzer". The following appears in the chat:

1) DT: Gehärteter Panzer isn't known.
2) DT: dt <link> (Get info on a task item)
3) DT: 4/ 8 [Gehrteter Panzer], 36-40 @ Tinnudir(WA)

Yes, you are right. 3) seems to be working fine and the umlaut "ä" does not appear in the name of the trophy. Can I get this also working for 1) and 2)?
GoldenDiablo is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-10-2011, 06:13 AM  
sheen
The Undefeated

Forum posts: 9
File comments: 6
Uploads: 0
I've tried to find a task item list in different language, but I can only find the US names : http://lorebook.lotro.com/wiki/Tasks_organized_by_tasks

I can't help you for translation unless I get this list.
Sorry I have not the time to check every task item name in every place in my localized game
sheen is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-10-2011, 05:48 AM  
ptweety
The Wary
 
ptweety's Avatar
Interface Author - Click to view interfaces

Forum posts: 2
File comments: 38
Uploads: 2
Quote:
This works fine for me in many cases but I have problems with german umlaut (right? I mean: ä, ö, ü, ...).

When I translate

"Hardened Carapace"

to

"Gehärteter Panzer"
Have you tried to encode umlauts like this:
Code:
ä	\195\164
Ä	\195\132
ö	\195\182
Ö	\195\150
ü	\195\188
Ü	\195\156
ß	\195\159
ptweety is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-10-2011, 01:40 AM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 538
Uploads: 8
Quote:
Hey there. There is a Monstrous Goo at Gwingris that the tool doesn't see.
Are you using the latest version (with no .plugindata file)?

For me it lists as:
DT: 1/ 4 [Monstrous Goo], 47-51 @ Gwingris(--)
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-10-2011, 01:37 AM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 538
Uploads: 8
Quote:
Do you have any idea how I can make the umlaut words also work?
First, I need to know if the problem occurs in all of these cases:
1) /dt (listing items in inventory)
2) /dt <name> (typing the item name on the command line)
3) /dt <link> (Using Ctrl-right-click on the item)

In all but the last case the function DT_Find is called to locate the data entry and it forces the names to upper case for the comparison. I suspect that is where the problem occurs. You might see if lower case works better.
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-09-2011, 11:07 PM  
matziq
The Unscathed

Forum posts: 15
File comments: 66
Uploads: 0
Hey there. There is a Monstrous Goo at Gwingris that the tool doesn't see.
matziq is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-09-2011, 12:08 PM  
GoldenDiablo
The Wary

Forum posts: 0
File comments: 7
Uploads: 0
Hey,

first, thank you for the nice plugin!

But I'm playing lotro on an european server and I'm in to translate the trophies from english to german language. I'm only update the

["N"] = "Grey Ear" },

to

["N"] = "Graues Ohr" },

This works fine for me in many cases but I have problems with german umlaut (right? I mean: ä, ö, ü, ...).

When I translate

"Hardened Carapace"

to

"Gehärteter Panzer"

like it is named in game, /dt can't find it. For every trophies without umlaut the plugin works nice with the german translation.

Do you have any idea how I can make the umlaut words also work?

Thanks!
GoldenDiablo is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-07-2011, 08:56 PM  
Vinny
The Indomitable
Interface Author - Click to view interfaces

Forum posts: 13
File comments: 538
Uploads: 8
Quote:
Great plugin !
Do you think you'll release a EU version ?

I guess it's a lot of work, all item have different name cause of multilanguage
I'm glad you like it. I'm only multi-lingual in computer languages, so someone else would need to translate it.
Vinny is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 07:37 AM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | VGInterface | LoTROInterface | MMOInterface | Swtorui