Quantcast
VGInterface.com
Search Downloads


Go Back   LoTROInterface > LotRO Stand-Alone Plugins > Bags, Bank & Inventory


Post A Reply
Author Comments Comment Options
Unread 10-09-2014, 06:00 PM  
Areswolf
The Wary

Forum posts: 1
File comments: 14
Uploads: 0
burgus34, you are an amazing person.

Your patch has totally fixed this mod.

I have rated your patch 5-stars, I would have given you 6 if I could.

Thanks again!
Areswolf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-09-2014, 11:24 AM  
burgus34
The Wary
 
burgus34's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 19
Uploads: 3
Quote:
I tried to load profile settings and there was no difference.

I tried to load default settings and there was no difference.

I'm set to max resolution and full screen.

I'm glad that you noticed the same phenomena on at least one toon. That confirms that something is up. I just can't fix it.

I have found the problem and uploaded a new version of my patch (v0.4.1).
The problem was a wrong value for calculating the Y-coord in widget-mode, if no settings are saved, or you have changed it to default-values.
Iīm not really shure if it was a bug that is older (since >90 slots), but it looks like that.

If you get the new file (only "settingsWidget.lua" has changed), you may set HugeBag to itīs default-values first, to recalculate the y-coord. Or you just delete the old settings-file (in .../PluginData/AccName/Server/CharName/HugeBagSettings.plugindata).

I hope your problem is solved with it.

Last edited by burgus34 : 10-09-2014 at 11:31 AM.
burgus34 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-07-2014, 11:08 PM  
Areswolf
The Wary

Forum posts: 1
File comments: 14
Uploads: 0
I tried to load profile settings and there was no difference.

I tried to load default settings and there was no difference.

I'm set to max resolution and full screen.

I'm glad that you noticed the same phenomena on at least one toon. That confirms that something is up. I just can't fix it.
Areswolf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-07-2014, 06:33 PM  
burgus34
The Wary
 
burgus34's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 19
Uploads: 3
Quote:
I can't find any setting to reposition or move the widget. The window can move fine but not the widget.

Hoping this gets addressed in the future or at least looking for some confirmation that it's not just me.

Thanks
Sorry that I answer a little bit late, but I didnīt have much time at the moment to check this out.
After I transfered a char from one server to another, the same problem happened on the transfered character, because there is no widget-position saved before for it (think so), Iīve tested the function "Load Profile Settings" and the problem is solved for that char.
If the same works on your char, than the problem may depend on the standart values that will be used, if no Widget-settings are saved.

So if this works for you, please response if it do the job, so that I can check where the problem is.
burgus34 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-06-2014, 12:30 PM  
Areswolf
The Wary

Forum posts: 1
File comments: 14
Uploads: 0
I can't find any setting to reposition or move the widget. The window can move fine but not the widget.

Hoping this gets addressed in the future or at least looking for some confirmation that it's not just me.

Thanks
Areswolf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-14-2014, 10:43 PM  
Stever1388
The Undying
Interface Author - Click to view interfaces

Forum posts: 29
File comments: 118
Uploads: 10
Without checking, it might be that Hugebag places the widget at a certain coordinate down the screen, and not a percent of the screen. So if you have a smaller screen than most (or smaller than Burgus) you may notice it gets cut off at the bottom and Burgus wouldn't. Changing the position of the widget to be 2/3rds down the screen instead of Y coordinate 700 for example would fix the problem. However, I haven't looked through the code to know if this is the case, but sounds like a possible cause and solution.
Stever1388 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-12-2014, 07:20 AM  
Areswolf
The Wary

Forum posts: 1
File comments: 14
Uploads: 0
Quote:
Another way is, that you rename the both setting-files stored at "plugindata/*Server*/AllCharacters" (named: HugeBagWindowProfileSettingsXX.plugindata and HugeBagWidgetProfileSettingsXX.plugindata -- XX=the Languageset e.g. EN), so you can reset the settings to its default.
I had cleared my settings during earlier attempts to correct this. I would just delete the settings files you mentioned and then the plugin would generate new ones the next time I started up.

The problem persists. Even after clearing settings, I still get the 11x10 widget.
Areswolf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-10-2014, 03:26 AM  
burgus34
The Wary
 
burgus34's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 19
Uploads: 3
Quote:
Burgus34, Thanks for your prompt attention and helpful ways!

No, this did not solve my problem. Installed as you instructed. The widget is still only 10x11 squares and doesn't show any of the buttons (i.e. sort, merge, etc)

In order for me to see my missing 10 items I need to change it to windowed mode.
Hmm, I did not noticed that on my installation.
If I have a little bit more time in the next days, Iīll try to check for a solution.

Another way is, that you rename the both setting-files stored at "plugindata/*Server*/AllCharacters" (named: HugeBagWindowProfileSettingsXX.plugindata and HugeBagWidgetProfileSettingsXX.plugindata -- XX=the Languageset e.g. EN), so you can reset the settings to its default.

Maybe this can help to find out what is going wrong, if you change the settings step by step and report problems with it.
.
burgus34 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-09-2014, 06:50 PM  
Areswolf
The Wary

Forum posts: 1
File comments: 14
Uploads: 0
Burgus34, Thanks for your prompt attention and helpful ways!

No, this did not solve my problem. Installed as you instructed. The widget is still only 10x11 squares and doesn't show any of the buttons (i.e. sort, merge, etc)

In order for me to see my missing 10 items I need to change it to windowed mode.
Areswolf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-08-2014, 03:01 PM  
burgus34
The Wary
 
burgus34's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 19
Uploads: 3
Re: Can't resize

Quote:
I have 120 spots and I installed the patch.

My problem is that when I'm using Widget mode I can't see the bottom row. When I switch to window mode, I can see them.

I tried to resize the widget according to the instructions (Hold left click in top or bottom left corner) but that doesn't seem to do anything at all. I get a little popup with up/down arrows and a mouse icon which has the right mouse button highlighted in green. The instructions say to hold left-button, but right-button is highlighted. Regardless, it doesn't matter because I've been trying both buttons and neither will resize my widget.

Any ideas?

Iīve patched also the settingsWindow.lua for this, I hope that itīll fix the problem for you ... The new patch (v0.3.1) you may find here

Last edited by burgus34 : 09-08-2014 at 03:18 PM.
burgus34 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 09-06-2014, 09:48 AM  
Areswolf
The Wary

Forum posts: 1
File comments: 14
Uploads: 0
Can't resize

I have 120 spots and I installed the patch.

My problem is that when I'm using Widget mode I can't see the bottom row. When I switch to window mode, I can see them.

I tried to resize the widget according to the instructions (Hold left click in top or bottom left corner) but that doesn't seem to do anything at all. I get a little popup with up/down arrows and a mouse icon which has the right mouse button highlighted in green. The instructions say to hold left-button, but right-button is highlighted. Regardless, it doesn't matter because I've been trying both buttons and neither will resize my widget.

Any ideas?
Areswolf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-30-2014, 07:01 AM  
burgus34
The Wary
 
burgus34's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 19
Uploads: 3
Quote:
I did what you said, but I got an error message in game and the plugin wouldn't load.

I noticed that the error message said something about it "expected to end" on line 107 (I have no concept or skill at programing whatsoever), so I deleted the word "end" in line 106 and left it in the new line in 107. After that, everything loaded just fine.

I guess it didn't like the two "ends" in there.

Thanks for a great plugin!

The description for the modification was incomplete, so I have added a working patch for this. You can find it here: HugeBag v1.13.66 Patch for 120 Slots, so you only have to overwrite the old file.

Last edited by burgus34 : 09-02-2014 at 02:47 PM.
burgus34 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-29-2014, 09:27 PM  
matheteis
The Wary

Forum posts: 0
File comments: 9
Uploads: 0
I did what you said, but I got an error message in game and the plugin wouldn't load.

I noticed that the error message said something about it "expected to end" on line 107 (I have no concept or skill at programing whatsoever), so I deleted the word "end" in line 106 and left it in the new line in 107. After that, everything loaded just fine.

I guess it didn't like the two "ends" in there.

Thanks for a great plugin!
matheteis is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-05-2014, 07:50 PM  
Stever1388
The Undying
Interface Author - Click to view interfaces

Forum posts: 29
File comments: 118
Uploads: 10
For those having problems with HugeBag opening the Turbine inventory, change your keybinding to open Bag 1 (which is normally F1) to whatever you normally use to open your inventory. This fixes the problem. I assume this won't be a problem for anyone since we're using HugeBag which is only 1 bag anyway, so we don't need to distinguish between Bag 1/2/3/etc.

For those that use the widget and it's not showing 120 slots correctly, if you open mainWidget.lua (use Notepad to open it), scroll down to line 106, after that line, create a new empty line and insert this:

Code:
elseif (backpackSize >= 111) and (backpackSize <= 120) then wHugeBag:SetSize( WinWidth, WinHeight + 139 ); end -- to show 111 to 120 slots
The whole thing should look something like this:

Code:
        if (backpackSize >= 45) and (backpackSize <= 55) then wHugeBag:SetSize( WinWidth, WinHeight - 71 ); -- to show 45 to 55 slots
	elseif (backpackSize >= 56) and (backpackSize <= 66) then wHugeBag:SetSize( WinWidth, WinHeight - 36 ); -- to show 56 to 66 slots
	elseif (backpackSize >= 67) and (backpackSize <= 77) then wHugeBag:SetSize( WinWidth, WinHeight - 1); -- to show 67 to 77 slots
	elseif (backpackSize >= 78) and (backpackSize <= 88) then wHugeBag:SetSize( WinWidth, WinHeight + 34 ); -- to show 78 to 88 slots
	elseif (backpackSize >= 89) and (backpackSize <= 99) then wHugeBag:SetSize( WinWidth, WinHeight + 69 ); -- to show 89 to 99 slots
	elseif (backpackSize >= 100) and (backpackSize <= 110) then wHugeBag:SetSize( WinWidth, WinHeight + 104 ); end -- to show 100 to 110 slots
        elseif (backpackSize >= 111) and (backpackSize <= 120) then wHugeBag:SetSize( WinWidth, WinHeight + 139 ); end -- to show 111 to 120 slots
	--**^
This should fix that problem. I haven't tested it though.

The only problem I have which I haven't been able to fix yet is that the slots in the window don't match up with the slots in the real bags, so when new items are entered into the inventory, they pop up all over the place in the HugeBag slots. Sorting the items places everything at the top. I'm not 100% sure what is happening, but it seems HugeBag gets messed up with what is "slot 1", "slot 2", "slot 3", etc in the real bags, and just places them wherever, but when it sorts it, it just always places items in the top slots, regardless of what the slot number is. I feel this should be fixable, but I haven't been able to figure it out yet.

Last edited by Stever1388 : 08-05-2014 at 07:52 PM.
Stever1388 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 07-04-2014, 09:50 AM  
Arkaedus
The Wary

Forum posts: 0
File comments: 1
Uploads: 0
Hi, and first all thanks fro this excellent plugin.

I can't use the Hugebag because i have 120 bag slots. Can you fix it to it can work with 120 bag slots?

Thanks

PD: I have the same problem that before post by Rodor.

Last edited by Arkaedus : 07-04-2014 at 09:52 AM.
Arkaedus is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 02:05 PM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | VGInterface | LoTROInterface | MMOInterface | Swtorui